¡Bienvenido a nuestra sección de preguntas y respuestas!

Aquí podrás realizar preguntas y recibir respuestas útiles de otros miembros de la comunidad.

¡Anímate a participar!


(Resuelto) - Cargar libreria ImageMagick en plesk VPS

0 votos
Hola,

Estoy configurando una galeria Piwigo en un servidor Plesk pero para ciertas opciones con las imágenes, necesitaria cargar la libreria ImageMagick. Como puedo hacerlo?

 

Gracias!
propuesto por situplastik (700 puntos) 2 Jul, 2013 en Plesk
editado por erojas 10 Ene, 2014

3 Respuestas

0 votos
 
Mejor respuesta

Si te da el siguiente error:

The following packages have unmet dependencies:
  php5-imagick: Depends: phpapi-20060613+lfs

Es que el paquete que necesitas requiere instalar previamente el phpapi-20060613+lfs, por lo que deberías instalar antes dicho paquete.

respondido por adau (29,590 puntos) 4 Jul, 2013
seleccionado por adau 3 Dic, 2013
Hola Adau,

He probado de instalar el paquete phpapi-20060613+lfs per no lo encuentra. He actualizado el archivo /ect/apt/sources.list con el repositorio " deb http://packages.dotdeb.org stable all " donde en principio si que esta el package, "apt-get update" para recargar paquetes y tampoco lo encuentra...
+1 voto
Hola,

Creo que me he confundido en la respuesta, el comando correcto seria:

apt-get install php5-imagick

No te olvides del backup!

Un saludo!
respondido por amarce (8,590 puntos) 2 Jul, 2013
Hola de nuevo,

 

He probado de instalar con apt-get pero he tenido problemas. Primero de todo he tenido que actualizar apt-get con "apt-get -f install" y una vez hecho, al volver a probarlo me comenta lo siguiente:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
 
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
  php5-imagick: Depends: phpapi-20060613+lfs
E: Broken packages
 
A que se refiere que es inestable? Como lo puedo instalar entonces?
 
Gracias!
0 votos
Hola,

Lo que deberias hacer es acceder mediante ssh y ejecutar el comando "apt-get install php5-imagemagick".

Recuerda realizar una copia de seguridad antes de lanzar el comando ya que este comando podria desinstalar los paquetes del sistema dependiendo de la antiguedad del sistema asi de su nivel de actualizaciones.

Un saludo!
respondido por amarce (8,590 puntos) 2 Jul, 2013

Preguntas relacionadas

0 votos
1 respuesta 426 vistas
0 votos
1 respuesta 70 vistas
+1 voto
1 respuesta 183 vistas
0 votos
1 respuesta 73 vistas
propuesto por jolual (1,180 puntos) 23 Feb, 2015 en Plesk
0 votos
1 respuesta 65 vistas
...