¡Bienvenido a nuestra sección de preguntas y respuestas!

Aquí podrás realizar preguntas y recibir respuestas útiles de otros miembros de la comunidad.

¡Anímate a participar!


(Resuelto) - Instalación YUM en Servidor VPS CentOS

0 votos

Buenas tardes,

estamos instalando YUM en un servidor VPS de centOS y hemos seguido los pasos que nos indican en https://siliconhosting.com/kb/questions/180 y nos encontramos con el siguiente mensaje de error

[root@g4r etc]# rpm -Uvh http://mirror.centos.org/centos/5.9/os/i386/CentOS/rpm-python-4.4.2.3-31.el5.i386.rpm

Retrieving http://mirror.centos.org/centos/5.9/os/i386/CentOS/rpm-python-4.4.2.3-31.el5.i386.rpm

warning: /var/tmp/rpm-xfer.6zzaYO: Header V3 DSA signature: NOKEY, key ID e8562897

error: Failed dependencies:

        popt = 1.10.2.3-31.el5 is needed by rpm-python-4.4.2.3-31.el5.i386

        rpm = 4.4.2.3-31.el5 is needed by rpm-python-4.4.2.3-31.el5.i386

        rpm-libs = 4.4.2.3-31.el5 is needed by rpm-python-4.4.2.3-31.el5.i386

[root@g4r etc]# rpm -qa|grep popt

popt-1.10.2.3-32.el5_9

[root@g4r etc]# rpm -qa|grep rpm

rpm-4.4.2.3-32.el5_9

Muchas gracias por vuestra ayuda. 

propuesto por g4r (150 puntos) 6 Sep, 2013 en Servidores Web
editado por erojas 10 Ene, 2014

1 Respuesta

0 votos
 
Mejor respuesta
Hola g4r!

Parece que el páquete de Python que estáis intentando instalar requiere unas versiones anteriores de popt, rpm y rpm-libs a las que tenéis.

Habéis intentado instalar el paquete del propio Yum para revisar exactamente qué versión del rpm de Python os está pidiendo?
respondido por adau (29,590 puntos) 6 Sep, 2013
seleccionado por adau 3 Dic, 2013

Preguntas relacionadas

0 votos
1 respuesta 294 vistas
0 votos
1 respuesta 426 vistas
0 votos
1 respuesta 50 vistas
propuesto por anónimo 8 Ene, 2014 en Plesk
0 votos
1 respuesta 101 vistas
propuesto por junker367 (170 puntos) 5 Nov, 2014 en Plesk
0 votos
1 respuesta 177 vistas
propuesto por anónimo 18 Sep, 2014 en Apache
...